Login / Sign up
> > > Java issue.....

Messages in topic: Java issue.....
Registered User

Nbr post: 2
Register: 11/25/14
Posted: 11/26/14 3:36 PM

Having trouble getting the Sync to work, Says my java is the issue. *** No JVM could be found on your system. Please define EXE4J_JAVA_HOME. To point to an istalled 64-bit JDK or JRE or download a JRE from www.java.com.****

I have the current Java, it is enabled on my browser. I have NO idea what this means or what to do about it. Meanwhile my 10 day premium trial is wasting away.

Can you help me?
Registered User

Nbr post: 1
Register: 6/19/14
Posted: 12/2/14 9:25 AM

I am having the same issue. There is a way to get it to work but you have to uninstall java then re install the 32bit and 64bit for it to work but as soon as you accept java update after doing that it will not work again. Wonder if this a known issue to magelo an if they intend to fix it to work properly with the updated java.I have uninstalled an re installed the 32bit an 64bit several times but its a losing battle due to every time wife or kids get on computer they decide to update java so i have to keep repeating what ive done every time i want to update my magelo
Registered User

Nbr post: 54
Register: 10/21/01
Posted: 12/9/14 1:31 AM

It is an old issue and it is back for me as well. I have DAI installed on my PC and had to uninstall the old Java and get the latest so now Magelo won't work and I once again have this error.

Can someone please answer why this error is back again?

I tried to fix this and I still get the error. I have Java 8 Update 25. But sad to say even going thru and identifying JAVA_HOME it refuses to recognize this is there. Also it is not in Program Files but in Program Files (x86). I have Windows 8.1 and this is latest version.

C:\Program Files (x86)\Java\jre7

This is what I identified as JAVA_HOME. It does not work.

Apparently Java says Explorer 10 (I have Explorer 11) runs 32 bit. I know that Magelo expects 64 bit. I have no idea what to do now. I sure hope someone comes by and helps me out.

I have the Enhanced Protected Mode enabled on IE 11. Supposedly I should get the 64 bit version altho I do not know HOW to see which one is currently on my PC.

Until I get some help means the money I just spent buying Magelo Premium was a waste of time.

UPDATE: I searched for Java Run Environment (JRE) specifically jre8. Not too good with this sort of thing but if anyone else is getting this issue go to www.java.com and get the run environment for 64 bit which is jre8 and it should fix the issue.

Premium User

Nbr post: 1
Register: 1/24/17
Posted: 1/6/20 10:43 AM

Over 5 years later, this still has not been fixed...

The problem appears to be that Java default install, as Alyssandra notes, goes into:

C:\Program Files (x86)\Java\

The solution is to install into this directory (which is apparently hard coded into Magelo):

C:\Program Files\Java\

I had to create an Oracle account and navigate to the manual downloads page:

Java SE Runtime Environment 8 Downloads

Download latest for x64, and point the installer to latter above directory.

For good measure, I set 'EXE4J_JAVA_HOME' to 'C:\Program Files\Java\jre1.8.0_231' - not sure if this was required or not, but Magelo sync is now working for me.

Note: it is clear that Magelo is broken, because when it cannot find JRE, a pop-up tells users to set EXE4J_JAVA_HOME, but setting this DOES NOT WORK if it points to installation inside the ...(x86) folder.