Login / Sign up
> > > Cannot down load file on start up


Messages in topic: Cannot down load file on start up
mxdog
Registered User

Nbr post: 6
Register: 11/10/13
Posted: 10/30/16, 12:44 AM

When I try to start magelo sync I get this message...

The launcher was unable to download a required file
(/sync/launcher/16/sync.launch?1616.1477801677021).

I am on windows 10 14393.351 and have both 64 bit and 32 bit java installed. My firewall is turned off to try to get this to work and I have tried to give http://www.magelocdn.com an exception in java. I also get the exact same message 32/64 bit with the exception of the "instance number?"

So I am not sure what is going on. If my network is blocking it or it just does not exist at magelo's end but from the logs looks like magelos- response 403.

Magelosync has worked great for me for years so I'm a bit mystified at present any help or suggestions are appreciated

HERE IS THE LOG FILE OUTPUT FROM THE LAST RUN:

Oct 30, 2016 12:36:51 AM com.magelo.update.launcher.Launcher run
SEVERE: Unable to retrieve start descriptor.
com.magelo.update.launcher.exception.DownloadException: Connection failure (host=www.magelocdn.com)
at com.magelo.update.launcher.Downloader.download(Downloader.java:111)
at com.magelo.update.launcher.Launcher.run(Launcher.java:109)
at com.magelo.update.launcher.Launcher.main(Launcher.java:70)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.exe4j.runtime.WinLauncher.main(Unknown Source)
Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.magelocdn.com/sync/launcher/16/sync.launch?16.1477802211268
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at com.magelo.update.launcher.Downloader.download(Downloader.java:80)
... 8 more


mxdog
Registered User

Nbr post: 6
Register: 11/10/13
Posted: 10/30/16, 1:12 AM

I tried drelk001 solution but I get a new number on every launch so same error could there be a write permission in the program or user folder that is causing this? I would think I wouldn't get a new file number one every launch. I mean that would add up to a huge amount of files on the server very quick.

Jelan
Admin

Nbr post: 11346
Register: 5/4/01
Posted: 10/30/16, 9:45 PM

Fixed, we changed our CDN provider and they had a default settings preventing our client from interacting with it...