Login / Sign up
> > > No JVM could be found on your system. Please define EXE4J_JA


Messages in topic: No JVM could be found on your system. Please define EXE4J_JA
wernickim
Premium User

Nbr post: 2
Register: 11/6/03
Posted: 4/18/20 4:21 PM

I note there are a number of posts on this subject. I downloaded the java package directly reference in the application notice as part of installing the Magelo Sync. The paths seems to be correct. I can access the java compiler from a command line so the path is set up correctly.

The Java 8 package is update 251 dated April 4 2020.. I've tried the fixes listed in the two posts without success. I have not tried using an older update.

A system with the old install works fine. I have checked the enviromental variables between the old system and the new install. They are exactly the same.

In short an older system works fine. I've tried a new install on a Surface and MSI labtop without success.

I have tried defining the EXE4J_JAVA_HOME variable without success. I'm not sure about the 32bit versus 64 bit.

The Surface I tried a new install is a Surface 2 Pro with 256GM of SSD. The MSI is a GS75 Stealth 95G. Anyone else having luck with a new install.I have tried reinstalling the Java 8 but I don't get past the message.
wernickim
Premium User

Nbr post: 2
Register: 11/6/03
Posted: 4/19/20 5:08 PM

The problem has been solved on both the Surface and MSI laptop. Basically, following instructions from previous posts.

1. Uninstall Magelo, Java 32 bit, and Java 64 bit.
2. Install Java 32 bit. Then, install Java 64 bit.
3. Finally install Magelo

I know both the Surface and MSI are 64 bit; however, the Surface worked with only the 32 bit Java. After installing Java 32 bit, Magelo was installed and it worked. The MSI would not work after installing Java 32 and then Magelo. I uninstalled Magelo. Installed Java 64 bit. Then installed Magelo. It worked

Jelan
Admin

Nbr post: 10852
Register: 5/4/01
Posted: 4/22/20 9:55 PM

Great to hear you sorted it out.
I need to embed the JRE with Magelo Sync to remove all this hassle...
Kaliaila
Premium User

Nbr post: 59
Register: 12/23/02
Posted: 5/10/20 8:01 PM

Getting this same error, https://www.dropbox.com/s/ilzffgesugpb0dj/Untitled.jpg?dl=0

But this is after a clean install of Windows 10, then installing Java, then installing Magelo. Have tried reinstalling some and all multiple times but still always get that message.
Jelan
Admin

Nbr post: 10852
Register: 5/4/01
Posted: 5/27/20 6:30 AM

Did you figure it out Kaliaila ?