Login / Sign up
> > > Character will not sync


Messages in topic: Character will not sync
Gochan
Premium User

Nbr post: 20
Register: 1/9/04
Posted: 2/21/21, 11:03 PM

Will not find character when trying to sync.
Jelan
Admin

Nbr post: 11348
Register: 5/4/01
Posted: 2/24/21, 1:32 AM

Hi Gochan,

Please post your Magelo Sync log if the problem persists, thanks.
vicex
Registered User

Nbr post: 1
Register: 7/23/13
Posted: 2/26/21, 8:37 AM

[08:34:00] [WARNING] Could not find: magelo-i18n []
[08:34:00] [INFO] Using magelo-i18n[en]
[08:34:00] [INFO] Using magelo-i18n[en_US]
[08:34:00] [INFO] Magelo Sync 4.6.3, Copyright (C) 2021 Magelo Limited
[08:34:00] [INFO] Windows 10 10.0 amd64
[08:34:00] [INFO] Java version 1.8.0_271
[08:34:00] [INFO] America/New_York, en_US, windows-1252
[08:34:00] [INFO]
[08:34:00] [INFO] Services initialisation ...
[08:34:01] [INFO] Automatic user authentification...
[08:34:01] [INFO] User : vicex (PREMIUM)
[08:34:01] [INFO] Game Slots : 1 free of 3
[08:34:01] [INFO] Starting services...
[08:34:01] [INFO] Starting service : Content Synchronizer
[08:34:01] [INFO] Starting service : Deadlock Hunter
[08:34:02] [INFO] Starting service : Game session seeker
[08:34:03] [INFO] New game session detected : eqgame.exe[6660]
[08:34:04] [INFO] Creating Everquest game monitor
[08:34:04] [INFO] Starting game monitor : EverQuest 3.7.4
[08:34:05] [INFO] [Char] Step -2
[08:34:06] [SEVERE] null
java.nio.BufferUnderflowException
at java.nio.Buffer.nextGetIndex(Unknown Source)
at java.nio.HeapByteBuffer.get(Unknown Source)
at magelo.fE.g(fE.java:3)
at magelo.eZ.a(eZ.java:10)
at magelo.eZ.a(eZ.java:3)
at magelo.QjI.Qa(QjI.java:10)
at magelo.QjI.Qa(QjI.java:49)
at magelo.QjI.Qa(QjI.java:38)
at magelo.QjI.a(QjI.java:42)
at magelo.e1.b(e1.java:5)
at magelo.QjF.Qa(QjF.java:22)
at magelo.QjF.Qa(QjF.java:46)
at magelo.QjF.Qa(QjF.java:47)
at magelo.Qes.Qa(Qes.java:910)
at magelo.Qes.i(Qes.java:792)
at magelo.g7.a(g7.java:19)
at magelo.g7.run(g7.java:2)
at java.lang.Thread.run(Unknown Source)
voelfgar
Premium User

Nbr post: 3
Register: 9/25/07
Posted: 3/2/21, 8:28 AM

I'm having the same problem. Here is my error log:

[07:23:10] [WARNING] Could not find: magelo-i18n []
[07:23:10] [INFO] Using magelo-i18n[en]
[07:23:10] [INFO] Using magelo-i18n[en_US]
[07:23:10] [INFO] Magelo Sync 4.6.3, Copyright (C) 2021 Magelo Limited
[07:23:10] [INFO] Windows 10 10.0 amd64
[07:23:10] [INFO] Java version 1.8.0_181
[07:23:10] [INFO] America/Chicago, en_US, windows-1252
[07:23:10] [INFO]
[07:23:10] [INFO] Services initialisation ...
[07:23:11] [INFO] Automatic user authentification...
[07:23:11] [INFO] User : voelfgar (PREMIUM)
[07:23:11] [INFO] Game Slots : 1 free of 3
[07:23:11] [INFO] Starting services...
[07:23:11] [INFO] Starting service : Content Synchronizer
[07:23:11] [INFO] Starting service : Deadlock Hunter
[07:23:13] [INFO] Starting service : Game session seeker
[07:23:14] [INFO] New game session detected : eqgame.exe[22112]
[07:23:14] [INFO] Creating Everquest game monitor
[07:23:14] [INFO] Starting game monitor : EverQuest 3.7.4
[07:23:15] [INFO] [Char] Step -2
[07:23:16] [INFO] [Char] Step -1
[07:23:16] [INFO] [Char] Step 0
[07:23:16] [INFO] [Char] Step 1
Mar 02, 2021 7:23:16 AM magelo.f0 a
SEVERE: Could not read CharInfo2 at: 0x3c3e4010 (3c3ef2e8) [299]
[CTX] 0x3c3da000 -> 0x3c3ef000 A:3 S:1

[07:23:16] [INFO] [Char] Step 11
[07:23:16] [INFO] [Char] Step 12
[07:23:16] [INFO] [Char] Step 2
[07:23:16] [INFO] [Char] Step 3
[07:23:16] [INFO] [Char] Step 31
[07:23:16] [INFO] [Char] Step 32
Mar 02, 2021 7:23:17 AM magelo.f0 a
SEVERE: Could not read CharInfo2 at: 0x3c3e4010 (3c3ef2e8) [299]
[CTX] 0x3c3da000 -> 0x3c3ef000 A:3 S:1

The final error message just repeats.

Here is the magelo.log file:
[2021-03-02 07:23:10] Could not find: magelo-i18n []
[2021-03-02 07:23:10] Using magelo-i18n[en]
[2021-03-02 07:23:10] Using magelo-i18n[en_US]
[2021-03-02 07:23:10] Magelo Sync 4.6.3, Copyright (C) 2021 Magelo Limited
[2021-03-02 07:23:10] Windows 10 10.0 amd64
[2021-03-02 07:23:10] Java version 1.8.0_181
[2021-03-02 07:23:10] America/Chicago, en_US, windows-1252
[2021-03-02 07:23:10]
[2021-03-02 07:23:10] Services initialisation ...
[2021-03-02 07:23:11] Automatic user authentification...
[2021-03-02 07:23:11] User : voelfgar (PREMIUM)
[2021-03-02 07:23:11] Game Slots : 1 free of 3
[2021-03-02 07:23:11] Starting services...
[2021-03-02 07:23:11] Starting service : Content Synchronizer
[2021-03-02 07:23:11] Starting service : Deadlock Hunter
[2021-03-02 07:23:13] Starting service : Game session seeker
[2021-03-02 07:23:14] New game session detected : eqgame.exe[22112]
[2021-03-02 07:23:14] Creating Everquest game monitor
[2021-03-02 07:23:14] Starting game monitor : EverQuest 3.7.4
[2021-03-02 07:23:15] [Char] Step -2
[2021-03-02 07:23:16] [Char] Step -1
[2021-03-02 07:23:16] [Char] Step 0
[2021-03-02 07:23:16] [Char] Step 1
[2021-03-02 07:23:16] [Char] Step 11
[2021-03-02 07:23:16] [Char] Step 12
[2021-03-02 07:23:16] [Char] Step 2
[2021-03-02 07:23:16] [Char] Step 3
[2021-03-02 07:23:16] [Char] Step 31
[2021-03-02 07:23:16] [Char] Step 32
[2021-03-02 07:24:11] Sending game content to server...
[2021-03-02 07:24:11] Detected game objects by GameMonitor (EverQuest 3.7.4) : 1
[2021-03-02 07:24:11] New detected game objects : 1
[2021-03-02 07:24:12] Game objects asked: 1
[2021-03-02 07:24:12] Sending observations
Jelan
Admin

Nbr post: 11348
Register: 5/4/01
Posted: 3/3/21, 10:54 PM

Hi voelfgar,

Your specific issue has been fixed, I have released an updated version of the everquest monitor that fixes it.

Hi vicex,

Still looking into that issue, will get back to you shortly.
Jelan
Admin

Nbr post: 11348
Register: 5/4/01
Posted: 3/5/21, 2:40 AM

Hi vicex,

I had a closer look at your issue, the error you have is not really usual and should not really be happening at all. That being said, i have added a safeguard so that if you or someone else would encounter it again, it would not crash Magelo Sync.